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General information  

 

General information  

 

Introduction 

 

All information about the software product is 

provided by this product manual. This manual 

is written for persons with a basic knowledge 

of installing and operating software controlled 

machines. General knowledge about safety at 

work as well as basic knowledge about PC 

handling, based on Microsoft Windows® 

operating system, is required. 

 

Availability 

 

This document must be available in complete 

and legible condition at the workplace near 

the machine. Any person, allowed to operate 

the machine, must read and understand this 

manual. The machine owner has the duty to 

ensure that all safety instructions, described in 

the manual, will be heeded by the operators. 

Notation 

 

To facilitate the reading and understanding of 

the document information text attributes, text 

notations and text structures are used. The 

text attributes (highlighting) inside this 

document are defined as follows: 

 

Attribute Function 

Bold Important information 

Italic Brand name 

Bold + Italic LPKF Brand name 

[…] Button 

\...\ Input or output field 

<…> Check box 

{…} Radio button 

>…>…> Menu path 

/…/ Pointer to a numeric character 
inside an image 

 

Images 

 

All pictures or graphics of this document are 

framed. Every figure is characterized with a 

continuously numbered title, for example “Fig. 

1: Overview“. Numeric character inside the 

image is used for the identification of specified 

components or operation steps. Sideward 

showing arrows inside the image are used to 

indicate an activity direction. 

 

Tables 

 

Any technical data, facts or special context 

will be organized in tables. Every table is 

characterized with a continuously numbered 

title, for example “Tab. 1: Scope of delivery“. 

The table will be created with a highlighted 

headline and labelled columns. 
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Procedure descriptions 

 

For this manual step by step procedures or 

workflows are compiled to operation sequen-

ces. An individual operation sequence 

consists of at least three components 

Title+Step+Result. 

 

Component Description 

■ Title Short description of the 
expected result – charac-
terized with a prefixed “■“. 

1. Step A consecutively numbered 
order of the individual work 
item of the described 
procedure. 

➨ Partial 

result 

Partial result of an operation 
step. The operation sequence 
is continuously progressed.  

♦ Result Result of the operation 
sequence - characterized with 
a prefixed “♦“. 

 

Symbols and signal words 

 

Inside this document the following symbols 

will be used to indicate important information: 

 

Symbol Description 

 

Safety instruction 

WARNING – dangerous hazard 
to people 
ATTENTION – a machine 
damage is possible 

 

Note 

The note will be used for any 
information about the optimal 
solution for a realisation of a 
specific function or operation. 

 

Note 

The memo will be used for any 
additional information about a 
function or operation step. 

© Copyright 

® Registered Trademark 

 

Registered trademark 

 

The LPKF logo and the LPKF product names 

are registered trademarks of LPKF Laser & 

Electronics AG. 

 

Microsoft  and Windows are brand names or 

registered trademarks  of the Microsoft Cor-

poration in USA and/or international. 

 

All other brand names belong to the respec-

tive owner.  
 

 

Standards 

 

The following standards and guidelines had 

been pursued for the creation of this 

document: 
 

Standard Description 

DIN 5008 

05-2005 

Rules for writing and layouting 

VDI 4500 
Bl.1,2 
11-2006 

Technical documentation - 
Definitions and legal basics 

DIN 66270 

01-1998 

Rate of software documents – 
Quality features 

ISO/IEC 
26514 

11-2008 

Requirements for designers and 
developers of user 
documentation 

IEEE 1063 

05-1987 

Standard for Software User 
Documentation 

ISO/IEC 

9294 

05-1990 

Guidelines for the management 
of software documentation 
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1 Function 

The system software LPKF CircuitPro is a powerful application that combines 

two important components of PCB production: Editing of design data and 

machine control. The circuit board plotters made by LPKF are controlled with 

this application running on Windows
®
 computers. 

LPKF CircuitPro imports your CAD data, aperture and tool lists and guides you 

step by step through the production of your PCB. Design data will be split up 

into the separate work steps and prepared for the production process. The 

integrated wizards will guide you through the whole PCB production process. 

They will inform you whenever you have to take action (e.g. manual tool change 

or turning over the material for producing a double-sided PCB). 

Use the “Design Rule Check” for checking the width and the spacing of the 

conductor tracks. Violations of the rules will be shown in the message view and 

graphically in the CAM View. Thus, you can make corrections before starting 

the production process. 

The current milling status and position are shown in the machining view, so that 

you can always keep an eye on the production process and progress. 

LPKF CircuitPro allows you to create templates for solder resist masks and 

legend printing. Additionally the software supports the automatic tool exchange 

with tool adjustment (depending on the machine type). 

The basic operation of the Windows
®
 graphical user interface is not part of this 

manual. If you are not familiar with using Windows
®
, please refer to the 

Windows
®
 user manual and online help. 

The scope of delivery of the CircuitPro application covers one machine license 

and multiple office licenses. 

 

Fig. 1: LPKF 

CircuitPro  
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1.1 Documentation overview 

The following documents are included with CircuitPro: 

• CircuitPro Basic Manual: This reference includes a short description of the 

most important functions in CircuitPro. The user interface is described in detail 

and the content of each menu item is explained. 

• CircuitPro Compendium: This compendium contains a detailed description 

of all menu items and functions and serves as a reference. The manual is 

available as a PDF file on the supplied installation CD. 

• CircuitPro UseCases: The use cases contain different tutorials for creating 

PCBs, engravings etc. Furthermore the basic CAM and machining operation 

steps are described. The corresponding tutor data is stored in: C:\My 

Documents\LPKF Laser & Electronics\ LPKF CircuitPro\Example Data. 

 
Pos: 3 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro_1.5/H andbuch/Kapitel_2_Sicher hei t/01_Sicherheitshinweise_Einl eitung @ 2\mod_1325773458644_2058.docx @ 49884 @ 1 @ 1 
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2 Safety notes 

The following chapter describes the most important safety notes while handling 

the software CircuitPro and the circuit board plotter. 

 
Pos: 4 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro_1.5/H andbuch/Kapitel_2_Sicher hei t/02_Allgemeine Sicher heitshi nweise @ 2\mod_1325773459520_2058.docx @ 49896 @ 2 @ 1 
 

2.1 General safety notes 

 

 

Note 

The usage of the software CircuitPro without the circuit board 

plotter has a low risk potential. 

 

 

DANGER 

Follow the safety notes! 

If you do not follow the safety notes injuries or accidents may 

occur.  

Read the manuals of the circuit board plotter and accordingly 

the control software carefully and follow the safety notes.  
 

 

DANGER 

Pay attention to a secure data transfer! 

A malfunction or interruption of data transmission between 

the PC and the circuit board plotter can cause uncontrolled 

machine reactions.  

Check the connection and replace defective or damaged 

cables immediately.  

 

 

DANGER 

Secure the machine against accidental switching on!  

Personal injuries may occur during manual tool exchange or 

maintenance if the machine is accidentally switched on. 

Always secure the machine against unauthorized use and 

accidental switching on.  

 

CAUTION 

Follow the safety regulations!  

The non-observance of the operational and regulatory health 

and safety regulations can cause serious personal injuries.  

Make sure that each operator knows the operational and 

regulatory health and safety regulations.  

 

 

DANGER 

Handling only by trained personnel!  

Improper operation of the machine can cause serious 

personal injuries. 

Instruct each user in handling the machine. 
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3 

3 Installation 

This chapter describes how to install the CircuitPro program. 
Pos: 6 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro_1.5/H andbuch/Kapitel_3_Installati on/02_Systemvor aussetzungen @ 2\mod_1325773470741_2058.docx @ 49920 @ 2 @ 1 
 

3.1 System requirements 

Following system requirements must be met for installing CircuitPro 

successfully: 

Table 1: System 

requirements 
Component Minimum requirement 

CPU 2 GHz 

RAM 2 GB 

Memory 2 GB 

Graphic board Dedicated with 128 MB memory (non-
shared memory) 

Following graphic boards may cause 
problems: 

 Intel 82945G 

Screen resolution 1024 x 768 pixel 

USB port 2 x USB 2.0  

 
Pos: 7 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro_1.5/H andbuch/Kapitel_3_Installati on/03_Installati on_CircuitPr o @ 2\mod_1325773471531_2058.docx @ 49932 @ 2 @ 1 
 

3.2 Installing the software 

 

 

ATTENTION 

Improper installation causes machine damage! 

An incorrect or incomplete installation of the software can 

cause damage to the machine.  

LPKF assumes no liability for damages to the machine 

caused by improper software installation.  

 

 

Note 

Please make sure that the machine is not connected to the 
computer.  

The USB cable must not be connected! 

 

 

 Installing CircuitPro 

1. Switch on the PC. 

2. Open the CD-ROM drive and insert the CD-ROM “CircuitPro“ into the drive. 

➨ The CD-ROM is read. The setup wizard starts automatically and the 

installation and update information is displayed in your browser's window: 
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Fig. 2: Installation 

and update 

information 

 

 

3. Close the browser window. 

Fig. 3: LPKF 

setup wizard 

 

 

4. Click on [Next] to start the installation procedure. 

 

 

Note 

Navigating in the installation program is done by clicking on 
[Back] and [Next]. Click on [Back] go to the previous installation 
step. Click on [Next] go to the next installation step. The 
installation is aborted by clicking on [Cancel]. 
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Fig. 4: License 

agreement 

 

 

5. Read the terms of the license agreement and click on {I Agree}. 

6. Click on [Next]. 

➨ Choose the folder where CircuitPro is to be installed: 

Fig. 5: Choosing 

the installation 

folder 

 

 

 

Note 

As default, the installation stores the program data in 
"C:\Programs\LPKF Laser & Electronics\LPKF CircuitPro 1.4\“. 

Click on [Browse] to install the program data in a folder of your 
choice. 

 

 

Note 

Click on [Back] to review the settings of the previous screens. 

Click on [Cancel] to cancel the installation. 

 

 

7. Click on [Next]. 

➨ The dialog to confirm the installation is displayed: 
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Fig. 6: Confirm 

installation 

 

 

8. Click on [Next]. 

➨ The installation of CircuitPro is started: 

Fig. 7: 

Installation of 

CircuitPro 1.5 

 

 

➨ The program is being installed on the PC. Progress of the installation is 

displayed. During the Installation the following warning message is 

displayed: 

Fig. 8: Warning 

message 

 

 

➨ When the installation is complete the following dialog is displayed: 
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Fig. 9: 

Installation 

complete 

 

 

9. Click on [Close] to exit the installation program. 

10. Close the browser window showing the installation and update information. 

 The CircuitPro program is installed. 

 

 

 

Note 

A link to the CircuitPro program was created on your desktop: 

 

 
Pos: 8 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro_1.5/H andbuch/Kapitel_3_Installati on/04_Maschi nenkonfiguration @ 2\mod_1325773472652_2058.docx @ 49944 @ 2 @ 1 
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3.3 Machine setup 

After CircuitPro has been installed on your PC, it has to be configured once for 

the machine and the accompanying equipment. The equipment configuration 

wizard helps you setting up the machine. 

 

 Setting up the machine 

1. Start CircuitPro. 

➨ The equipment configuration wizard starts automatically. 

Fig. 10: Start-up 

screen 

“Equipment 

configuration 

wizard” 

 

 

 

Note 

You can also start the equipment configuration wizard 
manually. Click in the menu bar of CircuitPro on 
Wizards>Equipment configuration wizard… 

 

2. Perform all the steps of the equipment configuration wizard and follow the 

corresponding instructions. 

➨ After the machine and the equipment are successfully configured a dialog 

window is shown which offers you to use the configuration data of older 

CircuitPro versions. 

 

 

Note 

If you have already installed an older version of CircuitPro on 
your computer, you can decide if you want to work with the 
existing configuration files. This means, the settings under the 
path “C:\Programs\LPKF Laser & Electronics\LPKF CircuitPro 
1.X\config” are used for the current installed version of CircuitPro 
1.5. These settings include the language and the machine 
configuration. 

 

3. Click on the respective CircuitPro version in the list “Version“ of the dialog 

window, which you want to use. Then click on [OK]. 
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Or 

3. Click on [Use default settings] to use the default settings of CircuitPro 1.5.  

➨ Right after machine configuration you will be prompted to choose a 

template file.  

➨ The following dialog is shown: 

Fig. 11: New 

document 

 

 

4. Select a template. 

5. Click on [OK]. 

➨ The CAM view is shown. 

 The machine is set up. The accompanying available equipment for 

producing PCB prototypes is also specified. 

 

  

 

Tip 

Language settings 

If you want to change the language of CircuitPro, act as follows: 

1. Click on Extras > Options. 

2. Change the value to “False” in row “Use OS culture”. 

3. Click on the row “Language” and change the value into the 

desired language.  
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4 Using the software 

The following chapter describes the usage of CircuitPro in detail.  

 
Pos: 10 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPro_1.5/Handbuch/Kapitel _4_Bedienung/1_Allgemein/02_CircuitPro_starten @ 2\mod_1325773494878_2058.docx @ 49968 @ 2 @ 1 
  

4.1  Starting CircuitPro 

 

 

Note 

The CircuitPro program must be fully installed and the machine 

must be connected correctly. 

 

 Starting CircuitPro 

1. Switch on the machine. 

2. Boot the PC. 

➨ The PC boots and starts the operating system. 

3. Start CircuitPro. 

➨ The following splash screen is displayed: 

Fig. 12: 

CircuitPro splash 

screen 

 

 

 The CircuitPro program is started and the user interface is displayed.  
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4.2 User interface 

The CircuitPro user interface is divided into several information and display 

panes that can be displayed or hidden as necessary. 

4.2.1 Structure of the CircuitPro user interface 

The user interface is structured as follows: 

Fig. 13:CircuitPro user interface  

 

 

  

6 

7 

2 3 

8 

9 
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10 

5 4 



 
CircuitPro 1.5  Using the software 

   

 

© 2012 LPKF AG  HB V1.0/Mai-12 21 

4 

 

Table 2: User 

interface 

 

No. Pane Name 

/1/  Menu bar 

/2/  “Standard” tool bar 

/3/  “Modify” tool bar  

/4/  “Prototyping” tool bar  

/5/  “Layouts” tool bar 

/6/  “Insert” tool bar 

/7/ Layers The “Layers” pane contains a table listing the 
individual layers of the circuit board to be processed. 

/8/ Navigation The “Navigation” pane displays an overview of the 
project with a zoom rectangle. 

/9/ CAM view Editing pane displaying a 2D representation of the 
project. 

 /10/ Status bar The status bar displays the coordinates of the current 
cursor position and of the anchor point. 
Measurement results are displayed in the “Length” 
field. 
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4.2.2 CAM View 

The CAM View allows you to regard the object to be processed two-dimensional 

and the corresponding layers. 

Move your cursor to menu View > CAM 2D… or click “CAM” on the toolbar 

“Layout” to open the following window: 

Fig. 14: CAM 

View 

 

 

In this view you are able to regard both sides of the PCB. According to the 

colors in the pane "Layers" each object on the board is highlighted. 
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4.2.3 Toolbar CAM view 

The toolbar “CAM view” provides following icons:  

 

Fig. 15: Toolbar 

CAM view 

 

 

 

 

The following table provides a brief description of the toolbar’s icons: 

Table 3: Toolbar 

CAM view 

 

No. Function description 

/1/ Selection: This arrow must be enabled to select or create objects in the CAM 

view. 

/2/ Fit all: Click on this icon to fit the whole layout into the CAM view. 

 /3/ Zoom area: Click on this icon and select an area that will be zoomed in 

afterwards.  

 /4/ Zoom: Click on this icon and move your mouse to zoom in/out the layout.  

 /5/ Pan: Click on this icon to move your whole layout to a desired position. 

 /6/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 

icon. If you click on a area in the layout again, this area will be zoomed in. 

 /7/ Polygonal Selection: Click on this icon to select objects by drawing 

polygons. 

 /8/ Remove last point: Removes the last point in the polygon.  

 /9/ Select: Selects the objects within the polygon.  

 /10/ Cancel: Cancels the creation of the polygon. 

 /11/ Set toolpath selection mode: Selects toolpaths within the created polygon. 

Three different modes are available: object, curve and element. 

 

  

1 2 9 3  11 10 4 5 6 7 8 



Using the software CircuitPro 1.5  
 

 

24 HB V1.0/Mai-12 © 2012 LPKF AG 

4 

 
Pos: 14 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPro_1.5/Handbuch/Kapitel _4_Bedienung/2_Fenster/2_M aschinenansicht/01_Fenster_M aschinenansicht_E33 @ 2\mod_1325773535451_2058.docx @ 50016 @ 3 @ 1 
 

4.2.4 Machining view E33  

The machining view enables you to regard your process data. 

Click on View > Machining 2D or click on the button “Machining“ to open the 

machining view. 

 

Fig. 16: 

Machining view 

E33 

 

 /1/ Work area /3/ Object to be processed 

 /2/ Axis of reflection /4/ Current head position 

 

If you start the production of a board the machine head’s movement, displayed 

as a cross line, is shown in the machining view.  
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4.2.5 Machining view S43 

The machining view enables you to regard your process data. 

Click on View > Machining 2D or on the button “Machining“ to open the 

machining view. 

  

Fig. 17: 

Machining view 

S43 

 

 /1/ Work area /3/ Obejct to be processed 

 /2/ Axis of reflection /4/ Current head position 

 

If you start the production of a board the machine head’s movement, displayed 

as a cross line, is shown in the machining view. 
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4.2.6 Machining view S63/S103  

The machining view enables you to regard your process data. 

Click on View > Machining 2D or click on the button “Machining“ to open the 

machining view. 

  

Fig. 18: 

Machining view 

S63/S103 

 

/1/ Current head position 

/2/ Tool holder 

/3/ Work area 

/4/ Axis of reflection 

/5/ Object to be processed 

 

  

 

The tool holder of the ProtoMat S63/S103 can pick up to 15 different tools. 

According to the colors of the tool’s distance rings, the circles in area /2/ are 

displayed in the same color.  

If you start the production of a board the machine head’s movement, displayed 

as a cross line, is shown in the machining view.  
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4.2.7 Toolbar Machining view 

The toolbar “Machining view” provides following icons: 

 

Fig. 19: Toolbar 

Machining view 

 

 

 

 

The following table provides a brief description of the toolbar’s icons: 

Table 4: Toolbar 

Machining view 

 

No. Function description 

/1/ Selection: This arrow must be enabled to select or create objects in the CAM 

view. 

/2/ Fit All only for Job Data: Only the job data is displayed. Other elements of 

the machining view are hidden. 

 /3/ Fit All for both Job Data and Machine Area: Scales and fits in the layout so 

that the elements of the machining view stay visible. 

 /4/ Zoom area: Click on this icon and select an area that will be zoomed in 

afterwards.  

 /5/ Zoom: Click on this icon and move your mouse to zoom in/out the layout.  

 /6/ Pan: Click on this icon to move your whole layout to a desired position. 

 /7/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 

icon. If you click on a area in the layout again, this area will be zoomed in. 

 /8/ Polygonal Selection: Click on this icon to select objects by drawing 

polygons. 

 /9/ Remove last point: Removes the last point in the polygon.  

 /10/ Select: Selects the objects within the polygon.  

 /11/ Cancel: Cancels the creation of the polygon. 

 /12/ Set toolpath selection mode: Selects toolpaths within the created polygon. 

Three different modes are available: object, curve and element. 
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4.2.8 3D View 

The 3D View allows you to regard the object to be processed three-

dimensional.  

Click on View > 3D View to open the following window: 

Fig. 1: 3D View 

 

 

Once you have imported a three-dimensional object, it will be shown in this 

view.  

 

 

Note 

Two-dimensional objects can also be shown in this 3D view. 

Therefore you have to highlight the corresponding toolpaths  in 

the pane “Toolpath“ and select “Display in 3D” in the context 

menu.  
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4.2.9 Toolbar 3D view 

The toolbar “3D view” provides following icons: 

 

Fig. 20: Toolbar 

3D view 

 

 

 

 

The following table provides a brief description of the toolbar’s icons: 

Table 5: Toolbar 

3D view 

 

No. Function description 

/1/ Selection: This arrow must be enabled to select or create objects in the CAM 

view. 

/2/ Fit all: Click on this icon to fit the whole layout into the CAM view. 

 /3/ Zoom area: Click on this icon and select an area that will be zoomed in 

afterwards.  

 /4/ Zoom: Click on this icon and move your mouse to zoom in/out the layout.  

 /5/ Pan: Click on this icon to move your whole layout to a desired position. 

 /6/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 

icon. If you click on a area in the layout again, this area will be zoomed in. 

 /7/ Top View: Displays the top side of the object. 

 /8/ Left View: Displays the left side of the object. 

 /9/ Rear View: Displays the rear side of the object. 

 /10/ Right View: Displays the right side of the object. 

 /11/ Bottom View: Displays the bottom side of the object. 

 /12/ Axonometric View: Standard view that displays the object in a 30° angle. 

 /13/ Rotate: Click on this icon to rotate your object in any direction by using your 

mouse. 

 /14/ Reset View: Resets the current view of your object. 
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4.3 Toolbars 

CircuitPro’s toolbars offer you a quick access to functions that are used most 

often. 

Fig. 21: 

Toolbars 

 

 

The follwing five toolbars exist in CircuitPro: 

• Standard 

• Insert 

• Modify 

• Prototyping 

• Layouts 

 

 

Note 

You are able to hide/display the toolbars. You can find this 

option under menu Tools > Customize… Go to tab “Toolbars” 

and enable/disable the corresponding checkboxes. 

 

You can arrange the toolbars anywhere on the surface of CircuitPro. 

 Changing the toolbar’s position 

1. Move the cursor to the top of the toolbar which is marked with several 

points.  

➨ The cursor takes the shape of a cross. 

2. Hold the left mouse button.  

3. Move the toolbar to the desired location on the user interface.  

 

 

Note 

You can arrange the toolbar on the left, bottom, right or top of 

the user interface.  

 

4. Release the left mouse button.  

 The toolbar is now fixed at the desired location of the user interface. 
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4.3.1 Toolbar Standard 

The toolbar “Standard” provides following icons:  

Fig. 6: Toolbar 

“Standard”  

 

 

The following table provides a brief description of the toolbar’s icons: 

Table 7: Function 

description 

“Standard“ 

 

No. Icon Function description 

/1/ New… Creates a new document in CircuitPro. Either you are 
able to create a document based on a standard 
template or you browse your hard disk for own 
templates.  

/2/ Open… Opens an existing CircuitPro document. 

/3/ Save Saves the currently edited document with all changes 
under the same name and location. 

/4/ Cut Cuts a selected area in the document. 

/5/ Copy Copies a selected area in the document. 

/6/ Paste Pastes the previously cut or copied region. 

/7/ Print Preview Opens a print preview of the current document. 

/8/ Print Opens the print dialogue. Make your settings for 
printing here. 

/9/ Undo Undo the last action in the document. 

/10/ Redo Redo the previously undone action. 

/11/ Delete Deletes the previously selected objects on the layer. 
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4.3.2 Toolbar “Insert” 

The toolbar “Insert” provides following icons: 

Fig. 8: Toolbar 

“Insert”  
 

 

The following table provides a brief description of the toolbar’s icons: 

Table 9: Function 

description 

“Insert” 

 

No. Icon Function description 

/1/ Create open path Creates an open path in the CAM View.  

/2/ Create closed path Creates a closed path in the CAM View. 

/3/ Create polygon Creates a polygon in the CAM View. 

/4/ Create rectangle Creates a rectangle in the CAM View 

/5/ Create circle Creates a circle in the CAM View. 

/6/ Create circle path Creates a circle path in the CAM View. 

/7/ Create flash Creates a flash in the CAM View. 

/8/ Create text object Creates a text in the Cam View. 

/9/ Fiducial Creates fiducials in the CAM View. 

/10/ Rubout area Creates a rubout area. 

/11/ Create polygon with cutouts Creates a polygon with cutouts in the CAM 
View. 

/12/ Create copper pouring Creates copper pouring. 

/13/ Switch line mode to 90° Enable the line mode, if you want to draw a 
horizontal line.  

/14/ Switch line mode to 45° Activate the line mode if you want to draw 
a straight line with a slope of 45°. 
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4.3.3 Toolbar “Modify” 

The toolbar “Modify” provides following icons:  

Fig. 22: Toolbar 

„Modify“ 

 

 

The following table provides a brief description of the toolbar’s icons: 

Table 10: 

Function 

description 

“Modify” 

 

No. Icon Function description 

/1/ Close curve Closes a curve. 

/2/ Combine curve Connects multiple points to a curve. 

/3/ Convert curve to polygon Converts the selected object to a polygon.  

/4/ Convert curve to path Converts the selected object to a path. 

/5/ Draw to flash Converts a drawn object to a flash. 

/6/ Combine objects to flash Connects objects to a flash. 

/7/ Compare objects to flash Compares objects with a flash.  

/8/ Transformation Translates, rotates, scales and inverts faces 
and toolpaths. 

/9/ Rotate objects 90° counter- 
clockwise 

Rotates the selected object 90° counter-
clockwise around the anchor point. 

/10/ Rotate objects 180° Rotates the selected object 180° around the 
anchor point. 

/11/ Rotate objects 270° 
counter clockwise 

Rotates the selected object 270° counter-
clockwise around the anchor point. 

/12/ Mirror objects along x-axis Mirrors the object at the anchor point along 
the x-axis.  

/13/ Mirror objects along y-axis Mirrors the object at the anchor point along 
the y-axis. 

/14/ Move selected objects Moves the selected object. 

/15/ Move a point or segment Moves a point or a segment.  

/16/ Cut a point or segment Cuts a point or a segment. 

/17/ Delete a point or segment Deletes a point or a segment. 

/18/ Create or move an arc Creates or moves an arc. 

/19/ Add a point or segment Adds a point or a segment. 
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4.3.4 Toolbar Prototyping 

The toolbar “Prototyping” provides following icons: 

Fig. 23: Toolbar 

“Prototyping”  

 

 

 

The following table provides a brief description of the toolbar’s icons: 

Tab. 11: 

Function 

description 

“Prototyping” 

 

No. Icon Function description 

/1/ Process planning wizard Starts the process planning wizard. 

/2/ Import Imports all files of the formats CAM, Excellon, 
Gerber, GerberX, LMD, HPGL, DXF and Sieb 
& Meyer. 

/3/ Rubout area Inserts a rubout area in the CAM view. 

/4/ Fiducial Inserts fiducials in the CAM view. 

/5/ Technology Dialog Generates insulation and contour routing 
toolpaths. 

/6/ Tool magazine Opens the dialog to edit the contents of the 
tool magazine.  

 /7/ Board Production Wizard Starts the Board Production Wizard. 

 /8/ Tool library Opens the tool library. 
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4.3.5 Toolbar Layout  

The toolbar “Layout“ provides following buttons: 

Fig. 12: Toolbar 

“Layout”  

 

 

The following table provides a brief description of the toolbar’s buttons: 

Tab. 13: Toolbar 

“Layout” 

 

No. Icon Function description 

/1/ CAM Distinction between the views CAM and 
Compact CAM. 

CAM: Displays all active views and panes. 

Compact CAM: Hides all views and panes 

except the CAM view and the panes 
“Navigation” and “Layers”. 

/2/ Machining Hides all views and panes except the 
machining view and the pane “Processing”. 
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4.4 Panes 

CircuitPro allows the arrangement of several individual panes on your screen. 

These are: 

 

• Layers 

• Geometry 

• Toolpath 

• Processing 

• Properties 

• Tool info 

• Navigation 

• Camera 

• Messages 

• Fault Monitor 

 

 Arranging the panes 

1. First, open the desired pane in the menu “View”. 

➨ The pane appears and is arranged on the bottom left of your screen. 

2. Double-click on the title of the pane.  

➨ The pane is now detached.  

 You are able to maximize/minimize the pane and to arrange it like desired. 

 

 Fixing the pane  

1. Click and hold the detached pane with the left mouse button.  

2. Move the pane.  

➨ In CircuitPro’s main window appear icons on the top, bottom, right and left 

side. 

3. Place the pane to one of the icons (top, bottom, left, right).  

 

 

Note 

Pay attention to place the cursor exactly on the icon before you 

release the left mouse button.  

 

4. Release the left mouse button. 

 The pane is now fixed on the desired position. 
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4.4.1 Layers 

The pane “Layers” lists the required layers for your project. Depending on the 

template that you select at the beginning of your project, the number and type of 

the layers diversify.  

Click on View > Layers to open the pane “Layers”: 

Fig. 14: Pane 

“Layers” 

 

 

The following table provides a brief description of the pane’s columns: 

Table 15: 

Columns in the 

pane “Layers”  

 

Column Description 

 Name Shows the name of the layer. 

The numbers shown in the brackets next to the layer 
name shows the number of the contained objects. 

 Visible Shows/hides the corresponding layer in CAM View.  

 Selectable Enable this function to make the layer selectable in 
CAM View. 

 Colors In this column each layer is assigned to a colour. The 
layers’ colours shown in the CAM View match these 
colours in the column.  

 Mode This list enables you to determine in which display 
mode the layer shall be shown.  

Tech Determine the layer’s processing goal in this column. 
I.e. for example, if you select the value "Solder 
Paste", you determine that this layer will be processed 
with solder paste later on. 

Inverse Mills the inside of the objects on the source layer. 
Example: In a letter or a number the inner area is 
milled. 

Phase Determines the phase in which the layer will be 
processed.  

 
[Z] Sorting function: sorts the layers by the display priority 

in Z direction.  
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4.4.2 Geometry 

The pane “Geometry” lists all apertures, which were imported from the Gerber 

and Excellon files. CircuitPro names the aperture list after the file name by 

default.  

Click on View > Geometry to open the pane “Geometry”. 

Fig. 24: Pane 

“Geometry” 
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4.4.3 Toolpath  

The pane “Toolpath” shows the board’s different production phases. 

Click on View > Toolpath to open the pane “Toolpath”. 

Fig. 16: Pane 

“Toolpath” 

 

 

The phases are named after the production steps. By clicking on the arrow 

symbol the tools used for this phase are shown. 
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4.4.4 Processing  

 

 

Note 

Please note, that several functions in sections „Select a Head“ 

and „Head actions“ are not available when using the ProtoMat 

S43/E33. 

 

In the "Processing" pane you can control the mill/drill head of the machine and 

determine its height. 

Click on View > Processing to open the pane “Processing”: 

Fig. 17: Pane 

“Processing” 
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Table 18: 

Processing  

 

No. Button Description 

X/Y - positioning 

/1/ 

 

Distance entry to move the machine 
head in X and Y direction. 

Enter the distance in the combo box 
and click on the arrow buttons. Each 
click moves the machine head at the 
specified distance in the preferred 
direction. 

/1/ 

 

Move head to the basic position: Click 
on this button to move the machine 
head to the basic position. 

/1/ 

 

Move head to the pause position: Click 
on this button to move the machine 
head to the pause position. 

/1/ 

 

Move head to the zero position: Click on 
this button to move the machine head to 
the zero position.  

/1/ 

 

Enables moving the head to the position 
selected by mouse click in the 
machining view.  

Z - positioning 

/2/ 

 

Distance entry to move the machine 
head in Z direction. 

Enter the distance in the combo box 
and click on the arrow buttons. Each 
click moves the machine head at the 
specified distance in the preferred 
direction. 

   

Select head 

/3/ 

 

Select the milling head as the active 
head. 

/3/ 

 

Select the camera head as the active 
head. 

/3/ 

 

Select the dispenser head as the active 
head. 

Head actions 

/4/ 

 

Moves the machine head upwards or 
downwards. 

/4/ 

 

Switches the spindle on/off. 

/4/ 

 

Clean dispenser. 

The button is only visible when the 
dispenser has been selected as the 
active machine head. 
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Table 18: 

Processing  

 

No. Button Description 

/4/ 

 

Switches the suction on/off. 

Process 

/5/ 

 

 

Starts processing. 

Please note the phase that is selected 
in the field below. 

/5/ 

 

 

Starts processing from the selected 
phase in the field below.  

All subsequent phases are processed 
one after another. 

/5/ 

 

Stops processing 

Tool info 

/6/ Displays the tool information for the tool that is currently located in the clamp. 
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4.4.5 Properties 

The pane “Properties” includes detailed information about the project. 

Click on View > Properties to open the pane “Properties”: 

Fig. 19: Pane 

“Properties” 

 

 

In this pane you find information about the tools, too. If you click on an aperture 

in the pane “Geometry”, you will get information about it, such as shape and 

diameter. 
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4.4.6 Tool Info  

The “Tool Info” pane displays the parameters of the tool located in the clamp. 

Click on display > Tool Info to open the “Tool Info” pane. 

Fig. 20: Pane 

“Tool info” 

 

 

The tool information displayed here is identical to the information provided in the 

tool library. 
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4.4.7 Navigation 

The pane “Navigation” is shown as soon as you have activated the CAM View 

or have clicked on View > Navigation: 

Fig. 21: Pane 

“Navigation” 
 

 

 
 /1/ Magnifying glass icons 

/2/ Reset zoom 

/3/ Zoom bar 

 

You see the object to be processed in small format in this pane. If you click on a 

certain position using the mouse, you can zoom in on this position by means of 

the zoom function. 

The following functions are available: 

• Minimise/enlarge the area selected with the mouse by using the +/- 

magnifying glass icons /1/. 

• Minimise/enlarge the area selected with the mouse by using the zoom bar 

/3/. 

• Reset the zoom or adapt the layout to the CAM view by clicking on button 

/2/. 
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4.4.8 Camera (only if a camera is connected) 

The pane “Camera” enables you to regard the object to be processed through 

the camera. 

Click on View > Camera to open the pane “Camera”. 

Fig. 25: Pane 

“Camera” 

 

 

 

Note 

Please note that a camera image is only displayed when a 
camera is actually available. This must be installed and 
connected via USB properly. 
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4.4.9 Messages 

Click on View > Messages to open the pane “Messages”. This pane contains 

information about: 

Fig. 26: Pane 

“Messages” 

 

 

Table 22: 

Messages  

 

Button Description 

Errors Errors are critical bugs. Click [Errors] in order to 
correct the errors. If the error recovery is not 
successful please call the LPKF Support. 

Warnings Warnings are input errors caused by the user. 
For example this may be information about 
cancelled or not properly executed actions. 

Messages Messages are statistical information of the 
program. This may be feedback from CircuitPro 
on certain actions performed, such as: “create 
new document”. 

 

Service Messages Service messages are displayed when the 
machine maintenance is due. Please contact the 
LPKF support. 

 

Raise selection Highlights the corresponding action in the CAM 
view. 

Example: You draw a rectangle. In the 
“Messages” pane appears a corresponding 
message (e.g. Rectangle Drawn_5 was 
created). Now if you click on the button “Raise 
selection” and hereafter on the message about 
the drawn rectangle, this rectangle is highlighted 
in the CAM view.  
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4.4.10 Fault Monitor 

The machine errors which have occurred are listed in the “Fault Monitor” pane. 

This machine error must be rectified so that production can be continued. 

Click on View > Fault Monitor to open the “Fault Monitor” pane: 

Fig.23 : 

Pane 

“Fault 

Monitor

” 

 

 

The icons used signify the following:  

Table 24: Error 

monitoring 
Icon Description 

 

Displays the first error message. 

 

Displays the previous error message. 

 

Displays the next error message. 

 
 

Displays the last error message. 

 
 

Acknowledges the error message currently marked. 

 
 

Acknowledges all error messages. 

 
 

Deletes the error message currently marked. 

 
 

Deletes all error messages. 

 

  



Using the software CircuitPro 1.5  
 

 

46 HB V1.0/Mai-12 © 2012 LPKF AG 

4 

 
Pos: 37 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPro_1.5/Handbuch/Kapitel _4_Bedienung/5_Menüs/1_M enü Allgemei n/01_M enü_Allgemein @ 2\mod_1325774530217_2058.docx @ 50290 @ 2 @ 1 
 

4.5 Menus 

This chapter describes each menu and the submenu of CircuitPro. 

Fig. 27: 

Menu bar 

CircuitPro  

 

CircuitPro’s menu bar contains following menu items: 

 

• File 

• Edit 

• Insert 

• Toolpath 

• Modify 

• View 

• Select 

• Wizards 

• Machining 

• Camera (only if a camera is mounted) 

• Extras 

• Help 
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4.5.1 Menu File 

The “File” menu contains the standard file operations of CircuitPro. 

Click on the “File” menu item to open the submenu: 

Fig. 28: Menu 

“File” 
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The following table contains short descriptions of the functions of the individual 

menu items: 

Table 25: “File” 

menu functions 

 

Menu item Description 

New… Creates a new document in CircuitPro. You can 
either select one of the standard templates for your 
new document or browse your disk drive for your 
own templates. 

Open… Opens a CircuitPro document. 

Recent files Contains a list of the five CircuitPro documents that 
have been opened/edited most recently. 

Save Saves the document currently edited with all 
changes made under the same file name and 
location. 

Save As… Saves the document currently edited with all 
changes made under the specified file name and 
location. 

Save As 
Template… 

Saves the current document as a template (file 
extension .cbf). Thus, it is displayed in the select 
template dialog. 

Import… Imports the following file formats: CAM, Excellon, 
Gerber, GerberX, LMD, HPGL, DXF, and Sieb & 
Meyer. 

Import 3D shape… Imports all 3D shapes in the STEP and IGES file 
formats. 

Import toolpath… Imports the toolpath data of an existing CircuitPro 
document. 

Recent files 
imported 

Contains a list of the five documents that have been 
imported most recently. 

Recent files 3D Contains a list of the CircuitPro 3D documents that 
have been opened/edited most recently. 

Export… Exports the toolpaths of the current document into 
an LMD file. 

Print Preview… Opens the print preview of the current document. 

Print… Opens the print dialog. Choose your settings for 
printing and start the print operation subsequently. 

Export to image… Exports the visual presentation or selected parts 
into an image file of the formats Bitmap, JPEG, or 
Windows Enhanced Metafile. 

 
Exit Closes CircuitPro. 
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4.5.2 Menu Edit 

 

The “Edit” menu contains the functions for editing objects in CircuitPro. 

Click on the menu item “Edit” to open the sub-menu: 

Fig. 29: Menu 

“Edit” 
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The following table contains short descriptions of the functions of the individual 

menu items: 

Table 26: “Edit” 

menu items 

 

Menu item Description 

Undo Undoes the last operation in the document.. 

Redo Restores the operation previously undone. 

Cut Cuts the selected object(s) from the document and 
stores it (them) in the clipboard. 

Copy Copies the selected object(s) to the clipboard. 

Paste Inserts the object(s) previously cut/copied at the 
selected position/on the selected layer. 

Material 
properties… 

Defines the properties (such as type and size) of the 
material used for 2.5D operations. 

Material 
placement… 

Defines the height and the position of the material 
used (2.5D objects) 

Material 
Settings… 

Opens the dialog “Material settings" where you can 
enter the parameters of the base material used. 

Tool magazine… Opens the dialog “Tool magazine” dialog. Enter the 
various tools that are/will be in the machine's tool 
magazine in this dialog. 

Tool Library… Opens a dialog showing all available tools. 

Aperture list 
library… 

Opens a dialog showing all apertures of the current 
document. 

Design Rule 
Check… 

Opens a dialog for the setting options and starting the 
design rule check. 

Measure Activate this menu item to measure the distance 
between two points in the 2D/3D/Machining view. The 
values are shown in the status bar of CircuitPro. 

Press the ESC key on your keyboard to deactivate 
this function. 

Distance… Opens the “Distance” dialog. The dialog shows the 
exact distance between two objects. 

Set anchor 
point… 

Opens a dialog where you can define the coordinates 
of the anchor point. 

Set zero point… Moves the zero point to the current anchor point. 

Move anchor to 
center point… 

Moves the anchor point to the center point of a 
selected object.  

Move layer to 
zero… 

Aligns the objects of the selected layer to the zero 
point. 

 
Match up layers… Opens a dialog allowing to align the objects of two 

layers along a vertical line. 

 
Match up 
objects… 

Opens a dialog allowing to move a source object onto 
a target object. 

 
Delete… Deletes the selected object(s) of the layer. 
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4.5.2.1 Material properties 

In the dialog “Material properties”, the properties of the 3D object to be 

processed can be determined. 

 Determining material properties 

1. Click on process > Material properties. 

➨ The following dialog is shown: 

Fig. 30: Material 

properties 

 

 

2. Select the material type in the field \Type:\. 

3. Enter the material width (in mm) in the field \Width:\. 

4. Enter the length of the material (in mm) in the field \Length:\. 

5. Enter the height of the material in the field \Height:\. 

 

 

Tip 

If you use the same material frequently, you can also set the 

specified values as default properties and save them. Activate 

the checkbox “Save as default properties”. 

 

6. Click on [OK] to adopt the values. 

 The material properties have been determined. 
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4.5.2.2 Material placement  

You can place the material in the maching view by using this dialog. You define 

the corners of the material as well as the surface height.  

 Placing the material 

1. Click on Edit > Material placement… 

➨ The following dialog is displayed: 

Fig. 31: Material 

placement 

 

 

 /1/ Material properties 

/2/ Machine properties 

/3/ Location 

/4/ Surface level 

 

The individual section contain the following information/functions: 

Table 27: Material 

placement 
Section Description 

Material properties In this section, the material properties of the material to be 
processed are displayed. You previously entered these 
properties in the dialog “Material properties”. 

Machine 
properties 

In this section, the current material side to be processed, is 
displayed. 

Location In this section, the material corners are set. Please take the 
exact instructions from the following pages. 

Surface level In this section, please set the surface height. Please take the 
exact instructions from the following pages. 

 

2. Modify the settings as required. 

3. Click on [OK] to save the values. 

➨ The dialog is closed. 

 The material was placed. 

1 2 

3 

4 
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 Set material corners 

1. Move the camera head to the left, lower corner of your base material: 

a) Click in the “Processing” pane. 

b) Use the arrow buttons in the section "X/Y positioning" to move the 

camera head. 

Fig. 32: Pane 

“Processing” 

 

 

 

Note 

The camera head is activated automatically. This can be 
recognised in the “Processing” pane by the green frame around 
the camera icon: 

 

 

 

Tip 

You can also click on the corner of your material in the 

machining view. The camera moves automatically to this 

position. Perform fine adjustment by using the X/Y buttons in the 

“Processing” pane. 

 

2. Perform autofocus for improved material alignment: 

a) To do this, click on the button "Autofocus" in the “Processing” pane: 

Fig. 33: 

Autofocus 

 

 

3. Position the camera head so that the corner of your material is exactly at 

the crosshairs: 
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Fig. 34: Crosshair 

of the camera 

 

 

 

Tip 

If you use the dark/reflective base materials (for example, POM), 

the display of the camera image can be too dark for the material 

to be recognised. 

In this case, turn the camera aperture to improve the incidence 

of light/lightness of the camera image. 

 

4. In the dialog “Material placement”, click on the following icon:  

➨ The value for the lower, left material corner was saved. 

➨ The following message is displayed: 

Fig. 35: Message 

for second 

position 

 

 

5. Confirm the message by clicking on “Yes”. 

➨ The camera automatically moves in the opposite corner of the material. 

6. Align the crosshairs with the material corner by using the X/Y buttons. 

7. Click on the symbol for the upper, right-hand corner:  

➨ The value was saved. 

 The material corners have been set. 
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 Setting the material height 

In the next step, the Z height of the material must be determined. 

➨ The following message is displayed after you have set the material corners: 

Abb. 36: Zur 

Messposition 

verfahren 

 

 

1. Confirm the message by clicking on “Yes”. 

2. Click on [Autofocus]. 

3. Now click on the button to set the material height:  

 The material height was set. 
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4.5.2.3 Material Settings 

Use this dialog to define the material properties of the object to be processed. 

Fig. 37: Material 

settings 

  

 /1/ Application 

/2/ Properties 

/3/ Location 

 

Section /1/ defines whether the material is used as a printed circuit board or as 

a front panel/engraving. 

The properties of the material are defined in section /2/. This comprises: 

• Material type (glass-reinforced epoxy laminate (FR4) or aluminium) 

• Thickness of the copper layer in µm 

• Material thickness in mm 

• Thickness of the underlay in mm (none if vacuum table is mounted) 

 

Section /3/ defines the location and size of the material area. In case of front 

panels/engravings, the Z height has to be determined by lowering the tool to the 

surface of the material. The following properties can also be defined: 

• Material width in mm 

• Material length in mm 

 

1 

 

2 

 

3 
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 When the material area is defined, the resulting surface height and the 

coordinates of the material's corners are displayed. 

 Defining the material area 

1. Click on the upper right corner of the working area in the machining view of 

the project. 

➨ The milling head moves to this position. The X and Y coordinates of this 

position are displayed in the “Material settings” dialog. 

Fig. 38: Material 

settings > 

coordinates 

 

 

 

Note 

If you have selected “Front panel/Engraving” in the 

“Application” section, you have to enter the Z coordinate at the 

material's corners. 

 Move the milling head downwards by changing the Z value 

until the tool touches the material. Follow the further 

instructions from step 2 onwards. 

 

2. Click on the icon representing the right rear corner, see /2/ in the following 

figure: 

Fig. 39: Material 

settings > 

Location 

 

 

 

 

2 1 



Using the software CircuitPro 1.5  
 

 

58 HB V1.0/Mai-12 © 2012 LPKF AG 

4 

 /1/ Left front corner  /2/ Right rear corner 

 

➨  The coordinates of the material area are stored.  

3. Click on the lower left corner of the working area in the machining view of 

the project. 

➨  The milling head moves to this position. The X and Y coordinates of this 

position are displayed in the “Material settings” dialog. 

4. Click on the icon representing the left front corner /1/. 

 

 

Tip 

After defining front left corner of the material area, you can also 

define the size of the material area by setting the “Material width” 

and “Material length”. 

1. Follow the steps 3 and 4 of “Defining the material area” 

2. Enter the values for \Material length\ and \Material width\ 

in millimetres. 

 The material area is adjusted automatically. 

 

 The material area is defined. 
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4.5.2.4 Tool magazine ProtoMat E33/S43 (manual tool change) 

The “Tool magazine” dialog moves the milling head to the zero position to allow 

a manual tool change. 

Click on Edit > Tool magazine… or the following icon of the toolbar to open the 

dialog: 

 

Fig. 40: Tool 

magazine icon 

 

 

The following dialog is displayed. 

Fig. 41: Tool 

magazine dialog 

for E33 and S43 

 

 /1/ Tool selection list /2/ Tool in clamp 

 

1 2 
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 Performing a manual tool change 

1. Select the tool that you want to mount into the clamp from the tool selection 

list /1/. 

 

 

Note 

This example uses the tool “Universal Cutter 0,2 mm”. 

 

 

 

2. Click on [Continue]. 

➨ The following message is displayed: 

Fig. 42: Tool 

change 

 

 

3. Mount the tool. 

4. Click on [OK]. 

 The manual tool change is finished. 

 

 Measuring the milling width 

 

Note 

Please note, that you can only measure the milling width of a 

conical tool. 

 

1. Click on [Milling Width]. 

➨ The following dialog is displayed: 

Fig. 43: Measure 

Milling Width 

 

 

2. Click on the position in the Machining view where you want to mill the line. 
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3. Enter the length of the line to be milled. 

4. Select an option: 

• Horizontal milling line 

• Vertical milling line 

5. Click on [Mill a Line]. 

➨ The line is milled at the selected position. 

6. Measure the milling width by using a microscope. 

 

 

Note 

To determine the correct milling width, put on the microscope 

at the lower, inner edges of the copper: 

 

 

7. Click on [Accept Width], if the milling width is okay. 

If not 

7. Adjust the tool manually and mill a line again until the result of the milling 

width is okay. 

 The milling width is measured. 
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4.5.2.5 Tool magazine ProtoMat S63/S103  

The tool magazine dialog lets you 

• view a list of the tools required for the current project, 

• view the tools currently present in the machine, 

• load the tool magazine, 

• view/put back the tool currently present in the clamp, 

• pick up a tool with the clamp, 

• check the milling width of a tool (only for Universal Cutter and Micro Cutter), 

• view the current state of the tool life spent and 

• replace an old tool with a new one. 

 

 

Note 

The “Tool magazine” dialog offers these options only for 

machines with automated tool change. This comprises the 

ProtoMat S63 and the ProtoMat S103. 

 

Click on Edit > Tool magazine… or the following icon of the toolbar to open the 

dialog: 
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Fig. 44: Tool 

magazine icon 

 

 

The following Dialog is displayed: 

Fig. 45: Tool 

magazine 

 

 

 /1/ Required tools 

/2/ Button “Check milling width…” 

/3/ Button “Discard tool” 

/4/ Tools in the machine 

 

It is necessary to load the tool magazine for processing a project. In section /1/, 

CircuitPro displays the tools that are required for processing the project. 

The required tools have to be inserted into the tool magazine manually. You can 

either 

• insert the tools into the tool holders and then assign them to the tool holders 

accordingly in section /4/ or 

• assign tools to the tool holders in the “Tool magazine” dialog and then insert 

the tools into the tool Holders according to the list. 

  

1 

2 3 4 
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 Loading the tool magazine  

1. Click on the drop-down list of the first tool holder: 

Fig. 46: Drop-

down list of the 

tool holder 

 

 

➨ A list of all tools that you can use with the machine is displayed. 

2. Select the required tool (in this case: Universal Cutter 0.2 mm, as in 

adjacent list): 

Fig. 47: 

Assigning a tool 

 

 

➨ The tool is marked with a green check mark in the list of the required tools. 

Also, a green check mark is displayed next to the corresponding drop-down 

list and the tool life spent is displayed on the right. 

3. Repeat above steps for all tools that are required for your project with the 

other tool holders. 
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Fig. 48: Tool 

magazine loaded 

 

 

 The tool magazine is loaded. 

 

 Picking up a tool with the clamp 

1. Click on the following button next to the drop-down list: 

Fig. 49: Picking 

up a tool 

 

 

➨ The following message is displayed while the clamp picks up the tool: 

Fig. 50: Message 

picking up tool 

 

 

➨ The symbol on the tool's button changes: 

Fig. 51: Tool 

currently in 

clamp 
 

 

 The tool is now in the clamp. 
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 Putting the tool back to its magazine position 

1. Click on the following button next to the drop-down list: 

Fig. 52: Putting 

down a tool 

 

 

➨ The following message is displayed while the clamp puts down the tool: 

Fig. 53: Message 

tool release 

 

 

➨ The symbol on the tool's button changes: 

Fig. 54: Tool not 

in clamp 

 

 

 The tool is back at its corresponding magazine position.  
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 Checking the milling width 

A tool has to be in the clamp to enable checking the milling width. 

A short line is milled that is subsequently measured with the camera. 

 

 

Note 

Please note that checking the milling width is only available for 

LPKF Universal Cutters and LPKF Micro Cutters. 

 

1. Pick up the tool with the clamp (see procedure “Picking up a tool with the 

clamp”). 

➨ The tool is now in the clamp. 

2. Activate the check box of the tool currently in the clamp: 

Fig. 55: Check 

box activated 

 

 

➨ The button “Check milling width…” is active. 

 

 

Note 

If a tool the milling width of which cannot be checked (e.g. 

Spiral Drill etc.) is in the clamp the button is not activated. 

 

3. Click on [Check milling width…]. 
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➨ The following message is displayed: 

Fig. 56: Defining 

a machine area 

 

 

4. Click on a position outside the area to be used for the project (but inside the 

processing area) to mill a line (see figure above). 

 

 

Note 

Please make sure that the milled line is inside the working area 

of the camera so that the camera can measure the line. 

 

➨ The milling head moves to the corresponding position in the processing 

area.  

5. Click on [OK]. 

➨ The dust extraction of the machine is switched on, the milling head moves 

to the zero position and the spindle motor is warmed up: 
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Fig. 57: Warm-up 

of spindle motor 

 

 

 

Note 

The warm-up may already have taken place before, if the 

machine has already processed material after switching it on. 

 

➨ The line to be milled is displayed in the machining view and the line is 

milled: 

Fig. 58: 

Machining view 

with milled line 

 

 

After the line has been milled the camera moves to the corresponding position. 

The “Camera” pane displays the line just milled: 
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Fig. 59: “Camera” 

pane 

 

 

➨  The dialog with the measurement results is displayed: 

Fig. 60: 

Measurement 

results 

 

 

If there is a difference between the desired milling width and the measured 

width CircuitPro automatically proposes a correction value. 

6. Click on [Store correction] to apply the proposed value. 

 

You can manually enter a correction value if you do not want to apply the value 

proposed by CircuitPro. 

7. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 

8. Click on [Store Correction]. 

 

If you do not want to apply any correction click on [Cancel]. 

➨ The dialog is closed. 

 The milling width of the tool currently in the clamp was checked. 
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Note 

Please note that the tool has to be put back into the holder and 

picked up again in order to have the corrected settings be 

applied. 

 

 Discarding a tool  

If the tool life of a tool is spent, the tool should be discarded to ensure optimum 

milling results. 

 

 

Note 

Please note that all information on the tool to be discarded will 

be deleted. 

 

1. Activate the check box of the tool to be discarded. 

➨ The button “Discard tool” is activated. 

Fig. 61: Replace 

tool 

 

 

2. Click on [Discard tool]. 

➨ The following message is displayed: 

Fig. 62: Tool 

replacement 

 

 

3. Confirm by clicking on [Yes]. 
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Note 

If the tool to be discarded is currently in the clamp, the tool is 

put back into its corresponding magazine position. 

 

➨  A message is displayed which prompts you to discard the tool. 

4. Replace the old tool in the machine with a new one. 

  The old tool is discarded. 
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4.5.3 Menu Insert 

The “Insert” contains the functions for creating objects in the CAM view. 

Click on the “Insert” menu item to open the submenu: 

Fig. 63: Menu 

“Insert” 

 

 

The following table contains short descriptions of the functions of the individual 

menu items: 

Table 28: “Insert” 

menu functions 

 

Menu item Description 

Open path… Creates an open path in the CAM view. 

Closed path… Creates a closed path in the CAM view. 

Polygon… Creates a polygon in the CAM view. 
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Table 28: “Insert” 

menu functions 

 

Menu item Description 

Rectangle… Creates a rectangle in the CAM view. 

Circle… Creates a circle in the CAM view. 

Circle path… Creates a circle path in the CAM view. 

Flash… Creates a flash object in the CAM view. 

Text… Creates a text object in the CAM view. 

Polygon with cutouts… Creates a polygon with cutouts in the CAM 
view. 

Copper pouring… Creates an insulated copper area around 
conductive tracks. 

Rubout area Creates an area where all unnecessary copper 
is removed. 

Fiducial Creates fiducials in the CAM view. 

Topography Creates grid points for recognizing the board 
topography. 

 
Drill hole… Inserts drill holes in the CAM view. 

 
Milling curve… Inserts a toolpath in the CAM view. 
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4.5.4 Menu Toolpath  

The “Toolpath” menu contains the functions for setting parameters and creating 

the paths for milling, routing, and dispensing solder paste. 

Click on the “Toolpath” menu item to open the submenu: 

Fig. 64: Menu 

“Toolpath” 

 

 

The following table contains short descriptions of the functions of the individual 

menu items: 

Table 29: 

“Toolpath” menu 

functions 

 

Menu item Description 

Dispense… Opens a dialog to create toolpaths for 
dispensing solder paste. 

2.5D milling… Creates toolpaths for 2.5D operations. 

Technology Dialog… Opens a dialog to create toolpaths for drilling 
and milling. 
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Table 29: 

“Toolpath” menu 

functions 

 

Menu item Description 

 
Edit breakout tabs… Opens a dialog to modify the breakout tabs in 

the contour-routing toolpath. 
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4.5.4.1 Create 2.5D milling  

To create a 3D part you need to create 2.5D toolpaths with a defined Z value.  

After creating your design in the CAM view Circuit Pro generates the necessary 

2.5D toolpaths to start the processing of your 3D part.  

 

 Creating 2.5D milling  

1. Click on Toolpath > 2.5D milling… 

➨ The following dialog is shown: 

Fig. 65: Create 

2.5D milling  

 

 /1/ Source 

/2/ Tool 

/3/ Options 

The sections contain following information/options: 

Table 30: Create 

2.5D milling 
Section Description 

Source Here the source object is displayed, the toolpaths are created 
for.  

Tool This list shows all available tools to generate 2.5D toolpaths.  

Options 

Generate on 
both sides 

In case of a double-sided object you can specify if the toolpaths 
should only be created on the top or bottom side. 

By default the toolpaths are generated on both sides of an 
object. 

 
Generate start 
drills 

Here you can specify if start drills should be created. The start 
drills are used by the milling tools to start milling a line.  

 Replace existing Here you can specify if already existing toolpaths should be 

1 

2 

3 
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Table 30: Create 

2.5D milling 
Section Description 

toolpath replaced. 

 

2. Activate the tool’s checkboxes that you want to use for creating the 2.5D 

toolpaths.  

3. Enable/disable the options you need for creating the toolpaths.  

 

 

Note 

Please note that at least one drilling tool must be enabled if 

you want to create start drills. 

 

4. Click on [OK]. 

 The 2.5D toolpaths are created.  
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4.5.4.2 Dispense 

The “Dispense” function lets you create solder paste paths  on a selected layer. 

Afterwards, You can place circuit components on the solder paste paths. 

Subsequently, the circuit boards can be soldered in a reflow oven (e.g. using 

the LPKF ProtoFlow). 

Fig. 66:Dispense 

paths created on 

pads 

 

 

 

Note 

The dispenser has to be mounted on the machine in order to 

create solder paste dots  on the circuit board! 

 

This dialog “Dispense” allows the following operations: 

• Creating new solder paste paths on the pads 

• Assigning new parameter sets to the dispense tools in the tool library 

[Add…] 

• Edit the parameters of the dispense tools [Edit…] 

• Edit details for creating solder paste paths [Show details] 

• Delete dispenser tools [Delete]. 
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 Creating a new solder paste path on the pads 

1. Click on Toolpath > Dispense. 

➨ The following dialog is displayed: 

Fig. 67: Dispense 

 

 /1/ List of the available dispense tools 

 

The table contains following columns: 

Table 31: 

Dispense 

 

Column Description 

Enabled Activates/deactivates the corresponding 
dispense tool with a check mark. 

Minimum size [µm] Shows the minimum pad size of the pad to be 
filled in µm. 

 
Dot distance [µm] Shows the dot distance between the individual 

solder paste dots in µm. 

 
Grid angle[°] Shows the rotation of the solder dot grid on the 

pad. 

 
Margin [µm] Shows the minimum distance of the solder 

paste dots to the boundary of the pad in µm. 

 
Tool Shows the corresponding dispense tool. 

 

2. In the “Source” drop-down list, select the layer where you want to create the 

solder paste path. 

 

 

Tip 

Create the solder paste dots on the designated solder paste 

layers (SolderPasteTop or SolderPasteBottom). 

 

  

1 
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3. In the list, select the dispense tools that you want to use. 

 

 

Note 

Take care that you have activated a suitable dispense tool for 

each pad size of your design. 

Several tools can be used for creating the solder paste paths. 

 

4. Click on [Apply]. 

5. Click on [Close]. 

 The solder paste path is created on the corresponding pads. 

 Adding new parameter sets for existing tools 

1. Click on [Add…] in the dialog. 

Fig. 68: Adding 

solder paste path 

parameters 

 

 

➨ The following dialog is displayed: 

Fig. 69: Pad size 

parameters 

 

 

2. Enter the minimum pad size of the pad in µm. 

3. Select a dispense tool. 

 

 

Note 

If the desired dispense tool is not in the list, you can create it in 

the tool library. 

For more information on adding tools to the tool library see the 

corresponding chapter. 

 

4. Enter the dot distance between the individual solder paste dots in µm. 

5. Enter a grid angle if necessary. 

6. Enter the margin width. 

7. Click on [OK]. 

➨ The new pad size parameters are displayed in the list. 

 The new pad size parameters are added. 
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 Editing existing pad size parameters 

1. Select the row where you want to edit the parameters and click on [Edit…]. 

Fig. 70: Editing 

pad size 

parameters 

 

➨ The dialog “Pad size parameters” with the details on pad size is displayed: 

Fig. 71: Pad size 

parameters 

 

 

2. Modify the parameters as desired. 

3. Click on [OK]. 

➨ The dialog “Pad size parameters” is closed. 

 The existing pad size parameters are modified. 

 

 Deleting existing pad size parameters 

1. Select the row that you want to delete and click on [Delete]. 

Fig. 72: Deleting 

pad size 

parameters 

 

 

 The selected row of existing pad size parameters is deleted. 
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 Showing details 

1. Click on [Show details] to display the global settings for creating solder 

paste dots: 

Fig. 73: Show 

details 

 

 

➨ The view changes as follows: 

Fig. 74: Details 

 

 

Table 32: Global 

settings 
Function Description 

Tolerance [µm] Defines the tolerance used when checking the 
distance of the solder dot to the pad boundary. 

Filling strategy If a pad is filled with more than one solder dot, 
the solder dots can be placed based on three 
filling strategies: 

 Cartesian grid 

 Hexagonal grid 

 Concentric 

 

Process direction Defines whether the pads are filled with solder 
paste “From center outwards” or “From 
boundary inwards”. 

Filling “From center outwards” is only available 
if you have selected the “Concentric” filling 
strategy. 

 

Apply smoothing This option is only active if you have selected 
the “Concentric” filling strategy. 

The solder paste dots are dispensed uniformly. 

 

Replace existing toolpath Replaces the existing solder paste path by the 
newly created solder paste path in the CAM 
view. 

If the option is deactivated, the new solder 
paste path is created over the existing one. 
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2. Modify the parameters if necessary. 

3. Click on [Apply]. 

➨ The changes are stored. 

 

 

Note 

Changes made in these fields are valid for all dispense tools. 

 

4. Click on [Close]. 

➨ The dialog is closed. 

 The details were shown. 
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4.5.4.3 Technology Dialog 

The technology dialog lets you create toolpaths that you can use in processing 

for the following steps: 

• Insulate 

• Contour routing 

• Drilling holes 

• Drilling fiducials 

• Milling pockets 

 Creating toolpaths 

1. Click on Toolpath > Technology dialog. 
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➨ The following dialog is displayed: 

Fig. 75: 

Technology 

dialog 

 

 

 /1/ Insulation options 

/2/ Contour routing options 

/3/ Options for creating holes, fiducials 
and pockets 

 

2. Activate the functions with check marks. 

3. Click on [Start]. 

➨ The following message is displayed: 

Fig. 76: 

Computation 

results 

 

 

 

1 

3 

2 
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Note 

The work steps and results of creating the toolpaths are listed 

in this dialog. If necessary, you can save or print its contents. 

 

4. Click on [Close] in the dialog. 

➨ The dialog with the computation results of the technology dialog is closed. 

 The toolpaths are created. 
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Insulate 

The “Insulate” section offers four different insulation methods: 

• Basic: Insulation with a single insulation channel and the shortest 

processing time. 

• Basic, pads double: Insulation with a single insulation channel and 

a double insulation channel for pads. Processing take a little more 

time than the “Basic” method. 

• Partial rubout: Insulation with a single insulation channel and 

removal of copper in defined areas. 

• Complete rubout: Entire removal of unnecessary copper. This is 

the most precise insulation method. 

 

Fig. 77: Insulate 

 

 

 

Table 33: Insulate 

 

Function Description 

Source Defines the layers where the insulation will be 
created. 

Primary Shows the tool that is used as  primary tool for 
the insulation process. 

 
Available tools This list contains the tools that are used as 

default for creating the individual toolpaths. 

 
Insulation width Defines the width of the insulation channel in 

mm. 

 

Pads insulation Defines the width of the pads insulation if an 
insulation method with an extra pads insulation 
is selected. 

 

Rubout Defines whether and on which layer a rubout is 
performed. In addition, you can select how the 
rubout area is going to be processed. 

 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Generate optimized 
rubout 

Optimizes the toolpaths for rubout areas with 
regard to the number of tools used. 
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Table 33: Insulate 

 

Function Description 

 

Remove Spikes Automatically remove residual copper that 
remains as spikes (e.g. between two 
connecting conductive tracks). This prevents 
that the copper in these areas is pulled off 
unintentionally by the cleaning pad during the 
final cleaning process. 

 

Force insulation Creates insulation paths for each individual 
insulation object. This guarantees insulation of 
every object even if the distance between two 
objects is smaller than the tool diameter. 

 

Perform inner insulation Defines for closed paths whether the inner 
contour is to be insulated in addition to the 
outer one. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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Contour Routing 

The “Contour Routing” section offers six different  routing methods: 

• Basic: Contour routing without gaps 

• Horizontal gaps: Contour routing with gaps on front and rear side. 

• Vertical gaps: Contour routing with gaps on left and right side 

• Edge gaps: Contour routing with one gap on each edge 

• Corner gaps: Contour routing with one gap in each corner 

• Equidistant gaps: Contour routing with equally spaced gaps 

 

Fig. 78: Contour 

Routing 

 

 

 

Table 34: Contour 

Routing 

 

Function Description 

Inside The toolpath is inside the drawn BoardOutline. 

Outside The toolpath is outside the drawn 
BoardOutline. 

 
Source Defines the layer(s) where the contour will be 

routed. 

 
Tool Defines the tool used for contour routing. 

 
Tabs position Defines the positions of the tabs, i.e. gaps in 

the routing. 

 
Gap width Defines the width of the tabs in mm. 

 

Distance Defines the distance of the tabs in mm.  
This value is only used in the “Equidistant 
gaps” routing method. 

 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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Drills 

The “Drills” options are for creating the toolpaths for holes in the circuit board. 

Fig. 79: Drills 

 

 

 

Table 35: Drills 

 

Function Description 

Source Defines the layer used for creating the holes. 

Tool Defines the tool used for drilling.  

 Usually, the tools are assigned to the holes 

automatically according to their diameters. 

 

Assign to Phase Defines the phase where the hole is created. 

 Usually, the holes are created in the phases 

“DrillingPlated” and “DrillingUnplated”. 

 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 

 
Create marking drills 

 
Marking tool Defines the tool used for marking. 

 

Phase Defines the phase where the markings are 
created. 

 Usually, the markings are created in the 

phase “MarkingDrills”. 
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Fiducials 

The “Fiducials” options are for creating the toolpaths for fiducial holes in the 

circuit board. The fiducials are used for correct alignment of the circuit board 

after it has been turned over for example. 

Fig. 80: Fiducials 

 

 

 

Table 36: 

Fiducials 

 

Function Description 

Source Defines the layer used for creating the 
fiducials. 

Tool Defines the tool used for creating the fiducials.  

 The tool “Spiral Drill 1.5mm” is 

automatically used for creating the fiducials. 

 

Assign to Phase Defines the phase where the fiducials are 
created. 

 Usually, the fiducials are created in the 

phase “Drill Fiducial”. 

 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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Pockets 

The “Pockets” options are for creating the toolpaths for pockets in the circuit 

board. 

Fig. 81: Pockets 

 

 

 

Table 37: Pockets 

 

Function Description 

Tool Defines the tool used for milling the pockets. 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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4.5.5 Menu Modify 

The “Modify” contains the functions to edit geometrical objects. 

Click on the “Modify” menu item to open the submenu: 
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Fig. 82: Menu 

“Modify” 

 

 

The following table contains short descriptions of the functions of the individual 

menu items: 

 

Table 38: 

“Modify” menu 

functions 

 

Menu item Description 

Close open path Closes an open path. 

Combine open paths Combines several open paths to a single open 
path. 

Convert to polygon Converts a closed path into a polygon. 

Convert to path Converts a polygon into a closed path. 

Draw to flash Converts a drawn object into a flash object and 
creates a new aperture. 

Combine to flash Combines objects to a flash object and creates 
a new aperture. 

Compare to flash Converts all objects that have the same form 
and size and are on the same as the selected 
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Table 38: 

“Modify” menu 

functions 

 

Menu item Description 

flash object. 

Explode flash Explodes complex flash objects into individual 
geometric forms. 

2.5D operations Opens the 2.5D operations sub-menu. 

Convert to 2.5D: This menu item applies a Z 

value to 2D objects thus converting them to 
2.5D objects. 

Change Z value: This menu item allows you 

to change the Z value of a 2.5D object. 

Transform… Opens a dialog to translate, rotate, scale and 
invert objects. 

Rotate/Mirror relative Opens the Rotate/Mirror sub-menu. 

• Rotate 90° 

• Rotate 180° 

• Rotate 270° 

• Mirror X 

• Mirror Y 

 

Step Repeat… Opens a dialog to multiply the selected objects 
with a defined spacing and count in X and/or Y 
direction. 

 
Pos: 51 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPro_1.5/Handbuch/Kapitel _4_Bedienung/5_Menüs/7_M enü Ansicht/01_M enü_Ansicht @ 2\mod_1325775268592_2058.docx @ 51226 @ 3 @ 1 
 

4.5.6 Menu View 

The menu “View” allows you to show/hide the different panes and open the 

layouts. 

Click on the “View” menu item to open the submenu: 
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Fig. 83: Menu 

“View” 

 

 

The following table provides a brief description of the menu item’s functions: 

Table 39: 

Menu 

functions 

“View” 

 

Menu item Description Fore more information, see 
chapter “Pane”  

Layers… Shows/hides the pane “Layers“. 4.4.1 Layers, on page 36 

Geometry… Shows/hides the pane “Geometry”. 4.4.2 Geometry, on page 37 

Toolpath… Shows/hides the pane “Toolpath”. 4.4.3 Toolpath, on page 37 

Processing… Shows/hides the pane 
“Processing”. 

4.4.4 Processing, on page 38 

Properties Shows/hides the pane “Properties”. 4.4.5 Properties, on page 41 

Tool info Shows/hides the pane “Tool info”. 4.4.6 Tool Info, on page 41 

CAM 2D… Opens the view “CAM 2D”.  

Machining 2D… Opens the view “Machining 2D”.  

3D View Opens the view “3D View”.  

Navigation Shows/hides the pane 
“Navigation”: 

4.4.7 Navigation, on page 42 

Camera… Shows/hides the pane “Camera”. 4.4.8 Camera on page 43 

Messages… Shows/hides the pane “Messages”. 4.4.9 Messages, on page 44 

Fault monitor… Shows/hides the pane “Fault 4.4.10 Fault Monitor, on page 
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Table 39: 

Menu 

functions 

“View” 

 

Menu item Description Fore more information, see 
chapter “Pane”  

Monitor”. 45 

 
Layouts Opens the sub menu “Layouts”.  

 

You find more information about the details of the different submenus in the 

corresponding topics of the chapter “XY”. 
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4.5.7 Menu Select 

The menu “Select” allows you to define the elements on the object which should 

be selected/highlighted by the mouse.  

Click on the “Select” menu item to open the submenu: 

Fig. 84: Menu 

“Select” 

 

 

The following table provides a brief description of the menu item’s functions: 

Table 40: Menu 

functions 

“Select” 

 

Menu item Description 

By Polygon Enable this option to create polygons by using your 
mouse and to select objects within the polygon.  

Invert in 2D Enable this option to invert your selection in the CAM 
View. 

Select all Selects all objects.  

Open/Closed path Selects open/closed path objects. 

Polygon Selects polygons. 
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Table 40: Menu 

functions 

“Select” 

 

Menu item Description 

Circle Selects circles. 

Rectangle Selects rectangles. 

Text Selects text objects. 

Flash Selects flash objects. 

Toolpath Selects toolpaths. 

 
Enable all Enables selection of all objects. 
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4.5.8 Menu Wizards 

This menu contains several wizards to help you in PCB manufacturing. 

Click on the “Wizards” menu item to open the submenu: 

Fig. 85: Menu 

“Wizards” 

 

 

The following table provides a brief description of the menu item’s functions: 

Table 41: Menu 

functions 

 

Menu item Description 

Equipment 
configuration wizard… 

Use the Equipment configuration wizard to define the 
existing equipment for the manufacturing of PCBs. 

Process planning 
wizard… 

Use this wizard to set the properties of the prototype 
project (for example: double sided with through 
plating). 

Board Production 
Wizard… 

This wizard guides you through every step of the PCB 
manufacturing. 

Dispense preparation 
wizard… 

Starts a wizard, which guides through the preparation 
of a dispense process. 

 
Dispense process 
wizard… 

Starts a wizard, which guides through a dispense 
process. 
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4.5.9 Menu Machining 

The menu “Machining” allows you to start/stop the processing and to make 

settings for the PCB processing. 

Click on the “Machining” menu item to open the submenu: 

Fig. 86: Menu 

“Processing” 

 

 

The following table provides a brief description of the menu item’s functions: 

Tab. 42: Menu 

functions 

“Machining” 

 

Menu item Description 

Process all Starts the production. 

Stop processing Stops the production. 

Production 
phase… 

Opens the dialog “Create new phase”. Then you can 
create a new production phase. 

Placement… Opens the dialog “Placement“. 

Fiducials… Inserts fiducials as toolpath in the machining view. 

Measure milling 
width… 

Only with conical surface milling tools: the current 
milling width is measured. 

Alignment… Opens the dialog “Alignment”. 

Drill reference 
holes… 

Opens the dialog “Drill reference holes”. 

Service…  Access to service functions for service staff. 

 
Determine camera 
head offset… 

Starts a dialog, which guides you through the 
procedure to determine the camera head offset. 

 
Teach tool-holder Measures the tool position by camera. 
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Tab. 42: Menu 

functions 

“Machining” 

 

Menu item Description 

positions… 

 

Connect… Opens the dialog “Connect…”. 

CircuitPro is connecting the machine. 
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4.5.9.1 Placement  

Use “Placement” to move and/or multiply the processing data in the Machining 

view of CircuitPro. 

Click on Machining > Placement to open the dialog. 

The section “Relative translation” lets you move the whole circuit board design 

within the machining view. 

 

 

Note 

Please note that you can move the processing data only as a 

whole and not individual toolpaths etc. 

 

The “Step and Repeat” section lets you multiply the circuit board design as 

desired in X and Y direction with a defined step distance. Thus you can produce 

several circuits on one panel. 

Fig. 87: 

Placement 

 

 

 Moving the processing data (relative translation) 

1. Enter a dX value. 

2. Enter a dY value. 

3. Click on [Apply]. 

 



 
CircuitPro 1.5  Using the software 

   

 

© 2012 LPKF AG  HB V1.0/Mai-12 95 

4 

 

Tip 

Procedure without entering X and Y values 

You can also move the processing data in the Machining view 

using your mouse. 

To do this, click on the processing data and while pressing the 

left mouse button drag the circuit frame to the position where 

you want to place the circuit design. 

 

➨ The circuit board date are placed at the corresponding position. 

 

Note 

If you want to move the processing data to the center of the 

working area, click on [Set center]. 

  

4. Click on [Close]. 

 The processing data are moved. 

 

 Rotating the processing data 

1. Enter the angle in the field \Angle\. 

2. Click on the buttons beside to rotate the processing data in the desired 

direction.  

 The processing data was rotated.  

 

 Multiplying the processing data 

1. Enter the number of circuits that are to be produced in X and Y direction. 

2. Enter the step distance of the circuits in X and Y direction. 

3. Click on [Apply]. 

➨ The circuits are created according to the values entered. 

4. Click on [Close]. 

 The processing data are multiplied. 

 

 

Note 

If you apply changes in the technology dialog that modify the 

bounding box of the current job (e.g. deactivating the contour 

routing or the fiducials) after having multiplied the circuit, you 

can adjust the job to the original placement values. 

The following warning is displayed if the toolpaths are 

recomputed in the technology dialog prompting you to execute 

the placement again. 
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 Click on [Reset] in the placement dialog. The current design 
is adjusted to the original placement values. 
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4.5.9.2 Fiducials 

Using the function "Fiducials," you can set the optical markings in the machining 

view of CircuitPro. These fiducials are only inserted into the layout as toolpaths 

and are not present as geometrical objects. This means that in the CAM view of 

CircuitPro, the fiducials which were created by this function are not displayed. 

 

 

Note 

In order to be able to perform this function, you must first 

generate the toolpaths so that the layout can be displayed in 

the machining view. 

 

Using the function "Fiducials” you can 

• set the fiducials in the machining view, 

• process the fiducials in the machining view and 

• delete the fiducials in the machine view. 

 

 Inserting fiducials 

 

 

Tip 

Ideally, set four fiducials in order to align the top and bottom side 

to each other. 

However, you can also work with two fiducials. In this case, 

these should be diagonally aligned to one another.  

 

1. Click on Machining > Fiducials… 

➨ The machining view of CircuitPro is activated. 

➨ The following dialog is displayed: 

Fig. 88: Fiducials 

 

 

2. Select the processing phase in the field \Phase\, in which the fiducials are to 

be generated. 

3. Select the drilling tool in the field \Tool\ for generating the fiducials. 

4. If not active, activate the mode {Insert}. 
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5. Enter the X and Y coordinates of the fiducials and click on [Set coordinates]. 

Or 

5. Using your mouse, on the machining view, click where you would like to 

place the fiducials. 

➨ The fiducial is inserted in the appropriate position in the machining view. 

 

 

Note 

Editing the coordinates of the fiducials 

If you would like to change the coordinates of a fiducial, proceed 
as follows: 

1. Activate the mode "Edit". 

 The coordinates of the last fiducial set are shown.  

2. Change the coordinates and click on [Set coordinates]. 

or 

2.   Select the fiducial and move this to the desired position 
in the machining view. 

 The coordinates have been edited. 

 

 

Note 

Delete fiducial 

If you would like to delete a fiducial, proceed as follows: 

1. Activate the mode "Edit". 

 The coordinates of the last fiducial set are shown.  

2. Select the fiducial to be deleted. 
3. Click on [Remove]. 

 

!!! If you have deleted the coordinates of the fiducial, the 
coordinates of the fiducial set previously are shown 
automatically!!! 

 

 The fiducial has been deleted. 

 

6. Please repeat step 5 until you have generated the desired number of 

fiducials. 

➨ A rectangle, which highlights the position of the fiducials, is created around 

the layout: 
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Fig. 89: Fiducial 

marks in the 

machining view. 

 

 /1/ Fiducials /2/ Rectangle 

 

7. Click on [Close]. 

➨ The dialog is closed. 

 The fiducials were inserted. 
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4.5.9.3 Alignment (only if camera is present)  

The dialog “Alignment” allows you modify the settings for the “ReadFiducials” 

phase. 

 Modifying the settings for phase “ReadFiducials” 

1. Click on Machining > Alignment. 

➨ The following dialog is displayed: 

Fig. 90: 

Alignment 

 

 

2 1 
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2. Select the existing fiducials in the design that are to be used in the 

“DrillFiducials” phase.  

3. Modify the individual parameters for the “ReadFiducials” phase as 

necessary. 

 

Table 43: 

Alignment 

 

Option Description 

Fiducials for step-
and-repeat 

Use fiducials of original project only: If the circuit 

board is multiplied with “Step and repeat” the 
fiducials are multiplied as well. 

Use outer fiducials of entire multiplied project: If 

the circuit board is multiplied with “Step and repeat” 
the fiducials are not multiplied. 

Diameter Tolerance Defines the tolerance for the diameter of the fiducial. 

Search Area Length Defines the size of the search area. 

 
Minimum Fiducial 
Quality 

Defines the quality level that a found fiducial must 
meet in order to be centered. 

 
Distance for Direct 
Acceptance 

Defines how precisely the fiducial must be centered 
in the camera image. 

 
Show Fiducial Time Defines the time that the camera remains on a 

found fiducial before continuing the process. 

 
Maximum No. of 
centering Tries 

Defines the maximum number of tries to center a 
found fiducial in the camera image. 

 
Manual Centering If 
Not Found 

If no fiducial is found, a dialog for manual centering 
is displayed. 

 
Ask for 
Confirmation 

After finding and centering a fiducial, the fiducial 
must be confirmed. 

 

4. Modify the settings as desired. 

5. Click on [OK]. 

 The settings for the “ReadFiducials” phase are applied. 
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4.5.9.4 Drill reference holes 

Use “Drill reference holes” to drill the holes for the reference pins. 

 

 

Note 

The reference hole system can be used for aligning the board 

if no camera is available. 

The reference hole system is not used if a vacuum table is 

mounted. 

 

Click on Machining > Drill reference holes to open following dialog: 
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Fig. 91: Drill 

reference holes 

 

 

There are three options for drilling reference holes to choose from: 

• Drill Both Reference Holes: One reference hole is drilled at the home 

position and one opposite to the home position. 

• Drill Reference Hole at Home Position: A reference hole is drilled at the 

home position. 

• Drill Reference Hole Opposite To Home Position: A reference hole is 

drilled at the position opposite to the home position. 

 

 Drilling reference holes 

1. Select the desired option for drilling the reference holes in the “Operations” 

section. 

 

 

Note 

The “Parameters” section contains LPKF standard settings. 

These settings are activated by default. If you want to use 

different values, remove the check mark at <Use LPKF 

Standard Settings>. 

 

2. Enter the offset value and the distance between the reference holes in the 

“Parameters” section if necessary. 

3. Click on [Start]. 

➨ The milling head moves to the corresponding position(s) and drills the 

reference hole(s). 
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Note 

The reference holes are drilled using a Spiral Drill 2.95 mm. 

This tool must be present in the tool magazine or, in case of 

machines without tool magazine, must be inserted manually 

into the clamp (when prompted). 

 

 The reference holes are drilled. 
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4.5.9.5 Connect 

The menu item “Connect” allows the following operations: 

• Connect CircuitPro with an LPKF ProtoMat machine [Connect]. 

• Disconnect CircuitPro from the LPKF ProtoMat machine [Disconnect]. 

• If CircuitPro is currently connected to an LPKF ProtoMat machine: Select a 

different machine type [Switch To]. 

 

 

Note 

This step is only necessary if you switch on the ProtoMat 

machine after starting CircuitPro 

or  

if you want to connect CircuitPro to a ProtoMat machine that 

differs from the one configured previously. 

 

 Connecting CircuitPro with an LPKF ProtoMat machine 

1. Click on Machining > Connect… 

➨ The following dialog is displayed: 

Fig. 92: Connect 

the machine 

 

 

2. Select your machine type in the drop-down list. 

 

 

Tip 

CircuitPro provides a virtual machine for simulating processes. 

You can connect CircuitPro to the virtual machine at any time, 

even when no real machine is connected to the PC. 

 

3. Click on [Connect]. 

➨ The following message window is displayed: 
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Fig. 93: 

Connection steps 

 

 

 CircuitPro is connected to the ProtoMat machine. 

 

 Disconnecting CircuitPro from the LPKF ProtoMat machine  

1. Click on Machining > Connect… 

2. Click on [Disconnect]. 

 CircuitPro is disconnected from the LPKF ProtoMat machine. 

 

 Switching CircuitPro to a different LPKF ProtoMat machine 

1. Select the machine type in the drop-down list. 

2. Click on [Switch To]. 

➨ The message window for the connection steps is displayed. 

 The connection of CircuitPro is switched to the other machine. 
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4.5.10 Menu Camera 

The menu “Camera” allows you to change the settings of the camera. 

Click on the “Camera” menu item to open the submenu: 

Fig. 94: Menu 

“Camera” 

 

 

The following table provides a brief description of the menu item’s functions: 

 

Tab. 44: Menu Menu item Description 
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functions 

“Camera” 

 

Options Opens the submenu “Options”. 

Actions Opens the submenu “Actions”. 

Movement Opens the submenu “Movement”. 

Overlay Opens the submenu “Overlay”. 

 
Search Opens the submenu “Search”. 
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4.5.11 Menu Extras 

The menu “Extras” allows you to change the program settings. 

Click on the “Extras” menu item to open the submenu: 

Fig. 95: Menu 

“Extras” 

 

 

The following table provides a brief description of the menu item’s functions: 

Table 45: Menu 

functions 

“Extras” 

 

Menu item Description 

Options… Opens the dialog “Options”. 

 
Customize… Opens the dialog “Customize”. 
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4.5.12 Menu Help 

The menu “Help” provides information about the current software version. 

Click on the “Help” menu item to open the submenu: 

Fig. 96: Menu 

“Help” 

 

 

The following table provides a brief description of the menu item’s functions: 

Table 46: Menu 

functions “Help” 

 

Menu item Description 

Help Opens the CircuitPro compendium. 

About… Opens the dialog “About this program“ that contains 
information about CircuitPro. 

 
System 
information… 

Contains information about the computer CircuitPro is 
installed on. 
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